aboutsummaryrefslogtreecommitdiffstats
path: root/perl-file-tail [moved to community]
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2013-08-27 00:51:37 +0200
committerMattias Andrée <maandree@operamail.com>2013-08-27 00:51:37 +0200
commitcd2ce3ebe33f7f60066c8a489f7736e273fd0636 (patch)
tree4a3e8bea35fc6f19b8967ba7b1cf9cf150bae547 /perl-file-tail [moved to community]
parentupdate dooble (diff)
downloadaur-packages-cd2ce3ebe33f7f60066c8a489f7736e273fd0636.tar.gz
aur-packages-cd2ce3ebe33f7f60066c8a489f7736e273fd0636.tar.bz2
aur-packages-cd2ce3ebe33f7f60066c8a489f7736e273fd0636.tar.xz
perl-file-tail has been moved into community
Signed-off-by: Mattias Andrée <maandree@operamail.com>
Diffstat (limited to 'perl-file-tail [moved to community]')
-rwxr-xr-xperl-file-tail [moved to community]/-watch-21
-rw-r--r--perl-file-tail [moved to community]/PKGBUILD27
2 files changed, 48 insertions, 0 deletions
diff --git a/perl-file-tail [moved to community]/-watch- b/perl-file-tail [moved to community]/-watch-
new file mode 100755
index 0000000..2f81b76
--- /dev/null
+++ b/perl-file-tail [moved to community]/-watch-
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+[ -f file-tail ] && rm file-tail
+
+wget 'http://search.cpan.org/~mgrabnar/File-Tail-0.99.3/Tail.pm' -O file-tail >/dev/null 2>/dev/null
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ grep 'Module Version:' < file-tail | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'perl-file-tail'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'perl-file-tail (unfetchable)'
+fi
+
diff --git a/perl-file-tail [moved to community]/PKGBUILD b/perl-file-tail [moved to community]/PKGBUILD
new file mode 100644
index 0000000..f048c58
--- /dev/null
+++ b/perl-file-tail [moved to community]/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Previous maintainer: Kevin Piche <kevin@archlinux.org>
+
+pkgname=perl-file-tail
+_realname=File-Tail
+pkgver=0.99.3
+pkgrel=5
+pkgdesc="Perl/CPAN File::Tail module for reading from continously updated files"
+arch=('any')
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/M/MG/MGRABNAR/${_realname}-$pkgver.tar.gz)
+md5sums=('ef0fb7bcb4181ba593f4a09940f61d1c')
+
+build() {
+ cd $srcdir/${_realname}-$pkgver
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/${_realname}-$pkgver
+ make install DESTDIR=${pkgdir}
+}